Modelism - RHC Forum: setare diver TB6560 - Modelism - RHC Forum

Salt la continut

Pagina 1 din 1

setare diver TB6560

#1 Useril este offline   ThePuiu 

  • Membru
  • PipPipPipPip
  • Grup: Members
  • Postari: 101
  • Inregistrat: 14-October 16
  • Gender:Male
  • Location:Oradea

Postat 15 May 2018 - 03:28 PM

Salut,
am o nelamurire cu setarile care trebuie facute pentru a invarti in parametrii optimi un motor pas cu pas NEMA17 de 0.5Nm (3.1V, 2.5A din fisa de catalog) folosind un Arduino Uno si libraria AccelStepper.h
Am legat driverul la motor si Arduino si am scris cateva linii de cod care sa imi permita sa invart motorul... de invartit se invarte dar ciudat...daca incerc sa il opresc cu mana se opreste foarte usor si cind il eliberez ramane nemiscat dar cu un tiuit si sta asa pana ii schimb din soft sensul de invartire cand incepe iarasi sa mearga normal. Nelamurirea mea este legata de setarea switch-urilor de pe driver... acestea sint in numar de 9 bucati dupa cum urmeaza (pentru cine nu cunoaste driverul):
- primele 4 sint pt setarea curentului: intre 0.3 si 3A (acum este pe 0.5A dupa ce le-am tot schimbat)
- urmatorul este Step Current 20% sau 50% (acum este 20%)
- urmatoarele 2 Excitation Mode 1,2,8,16 (acum este 1)
- ultimele 2 sunt Decay Settings 0, 25%, 50% si 100% (acum este 0)

O alta chestie interesanta: cu setarile curente si driverul alimentat la 12V curentul consumat este in jurul a 200mA. Daca cresc curentul am observat o chestie: voltmetrul sursei de alimentare arata 15.7V(!) iar curentul consumat creste la 0.5A desi setarea switchurilor este pe 1.5A. Motorul se invarte la fel de anemic dar mai face si un barait deranjant.
Va puteti da seama ce nu am facut bine?
Multumesc!
0

Arata acest topic


Pagina 1 din 1

1 useri citesc topicul
0 membri, 1 vizitatori, 0 utilizatori anonimi

913Creative.ro